SPSU Home >> Instructional Design >> Desire2Learn Faculty Support >> Faculty Getting Started >> D2L System Requirements

D2L System Requirements

System and software requirements

 

Required

Recommended

Operating system

Windows 98, 98SE, ME, 2000, 2003,
XP, Vista, Windows 7

Mac OS X

Windows 2003, XP
Service Pack 2

Video

SVGA monitor
Minimum resolution of 800 x 600

Resolution of 1024 x 768
or greater

Internet speed

56K modem

Cable modem, DSL

Sun Java Runtime
Environment (JRE)

JRE v1.4.2.x, 1.5.x, 1.6.x
(Required to run LiveRoom 4.3 and
Equation Editor.)

JRE 1.6 update 13

Java script

Enabled

Enabled

Cookies

Enabled

Enabled

Browser support

You can see what the support statuses mean in the Browser support lifecycle.

Windows

Browser

Status

Internet Explorer 10

Investigation

Internet Explorer 9

Supported (recommended)

Internet Explorer 8

Supported

Internet Explorer 7

Supported

Firefox (newest)

Investigation

Firefox 6.0 Supported

(recommended) Supported

Firefox 5.0

Supported

Firefox 4.0

Supported

Firefox 3.6

Maintenance

Firefox 3.5

Maintenance

Chrome (newest)

Supported

Mac OS X

Browser

Status

Firefox (newest)

Investigation

Firefox 6.0 Supported

(recommended) Supported

Firefox 5.0

Supported

Firefox 4.0

Supported

Firefox 3.6

Maintenance

Firefox 3.5

Maintenance

Chrome (newest)

Supported

Safari 5.0

Supported

Safari 4.0

Supported

Safari 3.1

Maintenance

Mobile web

Operating system/browser version

Status

iOS 3 (Safari)

Supported

iOS 4 (Safari)

Supported

Android 1.5

Supported

Android 2.1

Supported

Android 2.2

Investigation

Blackberry 6

Supported

The above mentioned products and/or services retain their trademarks and copyrights where applicable.